Fehler behoben: In Ihrer PHP-Installation scheint die von WordPress benötigte MySQL-Erweiterung zu fehlen

"In Ihrer PHP-Installation scheint die von WordPress benötigte MySQL-Erweiterung zu fehlen”Ist ein Fehler, auf den viele Blog- und Website-Besitzer stoßen WordPress.
Dies gibt keinen Anlass zur Sorge. Fehlende MySQL-Erweiterung from PHP ist typisch für Betriebssysteme, die von Grund auf neu installiert wurden, VPS oder dedizierte Server, bei denen PHP-Erweiterungen nicht Teil des Installationspakets waren. Dieses Problem ist bei beiden vorhanden Ubuntu und CentOS. In diesem Szenario wird das Problem sehr einfach mit einem PHP-Update und der Installation des Moduls gelöst. "php-mysql".
Aktualisieren Sie PHP und installieren Sie die MySQL-Erweiterung unter Ubuntu

apt-get update
apt-get install php-mysql

Aktualisieren Sie PHP und installieren Sie die MySQL-Erweiterung unter CentOS

yum update
yum install php70w-mysql

Nach diesem Schritt Starten Sie den Apache-Dienst neu oder NGINX.

Ich bin auch auf das Szenario gestoßen, in dem, obwohl die MySQL-Erweiterung in PHP vorhanden ist, in einem in WordPress erstellten Blog der Fehler "In Ihrer PHP-Installation scheint die von WordPress benötigte MySQL-Erweiterung zu fehlen" angezeigt wird. Meistens tritt der Fehler bei der Installation von WordPress auf. Diesmal erschien er jedoch auf einem Blog, der seit mehreren Jahren aktiv war.
In dieser Situation stellte ich fest, dass das Problem nicht bei den PHP-Modulen liegt, sondern bei der sehr alten Version von WordPress, die unter PHP 7.4.4RC1 nicht mehr kompatibel ist. Ein einfaches Upgrade von WordPress auf die neueste Version löste den Fehler.

Fehler behoben: In Ihrer PHP-Installation scheint die von WordPress benötigte MySQL-Erweiterung zu fehlen

Über den Autor

Stealth

Mit Leidenschaft für alles Gadget und IT schreibe ich gerne über Stealthsettings.com seit 2006 und ich möchte mit Ihnen neue Dinge über Computer und Betriebssysteme entdecken. macOS, Linux, Windows, iOS und Android.

Hinterlasse einen Kommentar