UPDATE PROBLEM: Der Server läuft PHP-Version, aber Wordpress 5.1.6 3.2.1 5.2.4 benötigt mindestens.

Hinweis für alle ist nicht bekannt, dass zu installieren oder tun UpgradeCPC auf eine neuere Version von 3.2Es ist notwendig, dass werden, um eine neuere Version der installierten 5.2.4.

Wenn der Server eine Version von PHP älter als 5.2.4 auf Version installieren WordPress 3.2.1Es erscheint Fehler / Mitteilung "Ihr Server läuft PHP-Version 5.1.6 Benötigt WordPress 3.2.1 aber zumindest 5.2.4".
Das Problem lässt sich sehr einfach durch ein Upgrade PHP gelöst werden, aber bevor Sie dies ein paar Dinge zu beachten. Zuerst Upgrade PHP-Hosting ist von einer Freigabe ausgeschlossen. So können Sie das Upgrade tun müssen über Administratorzugriff auf den Server haben (dedizierten Server oder VPS). In der zweiten, vor dem Upgrade muss Dokument vorsichtig sein, und dass eine neue Version von PHP nicht zu geben, Fehler anderen Seiten auf diesem Server gehostet.

für OS ist die am weitesten verbreitete Webserver (Agreart und / WHMWill) zeigen Ihnen, wie zu tun Upgrade auf PHP auf CentOS 5.2.10.x 5 32-bit.

Upgrade auf PHP 5.1.x 5.2.x auf 5-Bit CentOS 32.x

1. Prüfen Sie, welche Pakete / Module installiert sind PHP (ex. Php-mcrypt) zusätzlich zu den Standard-Paket. Wenn überhaupt, werden sie gelöscht oder actuzlizate werden.

Überprüfen Sie die installierten Pakete:

rpm -qa | grep php

old_php_version

2. Neuen Archiv erforderlich UpgradePHP-Version Besitzstand.

nano / etc / yum.repos.d / CentOS-Testing.repo

In der neu erstellten Datei (CentOS-Testing.repo) Die folgenden Zeilen (Kopieren / Einfügen) hinzufügen:

[C5-Test]
name = 5 CentOS-Testing
baseurl = http: //dev.centos.org/centos/$releasever/testing/$basearch/
enabled = 1
gpgcheck = 1
gpgkey = http: //dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Strg + X Datei CentOS-Testing.repo zu speichern.

3. PHP-Update über yum:

yum update

4. Wiederaufnahme / httpd :

service httpd restart

Nach dem Neustart httpd Version und überprüfen Sie die installierten Pakete:

new_php_version

Prüfen Sie, ob Fehler Module / Pakete:

php -v

Upgrade-PHP / 32-Bit CentOS (i386).

UPDATE PROBLEM: Der Server läuft PHP-Version, aber Wordpress 5.1.6 3.2.1 5.2.4 benötigt mindestens.

Über den Autor

Stealth LP

Gründer und Herausgeber Stealth-EinstellungenIn 2006 Datum.
Erfahrungen aus der Linux-Betriebssysteme (vor allem CentOS), Mac OS X, Windows XP> Windows-10 und Wordpress (CMS).

Hinterlasse einen Kommentar